VGMaps

Site Boards => Message Board Help => Topic started by: Trebor Almasy on July 31, 2009, 06:00:19 AM



Title: Site takes forever to load.
Post by: Trebor Almasy on July 31, 2009, 06:00:19 AM
This was actually something I noticed a while ago. But for some reason when going to a page that has a lot of maps (SNES, NES) the page takes FOREVER to load. Now I'm not talking about the maps themselves, they load fine, but the actual page with the links to the maps.

I've tried it with my main computer, my laptop and my school computer and all three have the exact same problem(two running Firefox and the school running IE) so I doubt it's me.

Most of the time on SNES it's so bad it stalls out my computer and I have to Alt-ctrl-del the browser.

Anyone else have the same or a similar issue?


Title: RE: Site takes forever to load.
Post by: snesmaster on July 31, 2009, 07:51:41 AM
If I'm using a dial up modem I have the problem of it taking forever.  However with high speed it is no so bad.  I have never had it crash my browser or computer before.  I use Firefox.


Title: RE: Site takes forever to load.
Post by: Maxim on July 31, 2009, 10:39:09 AM
They're huge pages. Both the NES and SNES pages are over 1MB just for the HTML. Jon needs to sort it out :)



I could make a half-assed attempt myself if I had the time... but a proper designer could do a much better job.


Title: RE: Site takes forever to load.
Post by: Revned on July 31, 2009, 05:38:47 PM
It takes awhile to load even with high speed.


Title: RE: Site takes forever to load.
Post by: DarkWolf on August 01, 2009, 06:27:53 AM
If Jon could split up the games into their own HTML files you could do some simple Ajax calls (especially if you used jquery) to load only the maps for just the game you selected.


Title: RE: Site takes forever to load.
Post by: Trebor Almasy on August 01, 2009, 08:11:20 AM
See, I didn't realize it loaded all the images.

That's kinda really REALLY bad website design (no personal offense to Jon), but wow.

I mean it should take MINUTES to load a page on a cable modem. There's just sooo many other ways to do it that it doesn't suck up the bandwidth/kill a computer.


Title: RE: Site takes forever to load.
Post by: Trebor Almasy on August 01, 2009, 08:11:53 AM
See, I didn't realize it loaded all the images.

That's kinda really REALLY bad website design (no personal offense to Jon), but wow.

I mean it should take MINUTES to load a page on a cable modem. There's just sooo many other ways to do it that it doesn't suck up the bandwidth/kill a computer.


Title: RE: Site takes forever to load.
Post by: DarkWolf on August 01, 2009, 11:00:52 AM
No, I meant it would only load the information about the game you selected instead of listing all of the maps on one page per platform.


Title: RE: Site takes forever to load.
Post by: JonLeung on August 01, 2009, 12:26:57 PM
Great, I lost another long post because my IE *@#!ed up again.



Summarized repost:



The pages were made in Microsoft Word back in 2002 (I didn't want to mess with coding).  Then I switched to Microsoft FrontPage which allowed my flexibility with the coding but also inserted a lot of unnecessary code.  Despite a "revamp" in 2006 - which was mostly just a redesigned front page and a palette swap from black to white - the atlas pages haven't truly changed much since.  Sure, there have been minor tweaks, but nothing I'd call an overhaul.  I guess the tables made sense when I only had a few maps on each page to begin with but maybe not now when we've got over 12000 and the biggest sections have 2000+ maps each.



For the possible revamp that keeps on coming up in discussion, the atlas structure is pretty much the main concern as to why we should even have a revamp.  So if and when I get to that, expect something more dynamic and efficient, ie. only pulling up the requested information.


Title: RE: Site takes forever to load.
Post by: Trebor Almasy on August 01, 2009, 06:33:15 PM
JonLeung Said:
Great, I lost another long post because my IE *@#!ed up again.



Summarized repost:



The pages were made in Microsoft Word back in 2002 (I didn't want to mess with coding).  Then I switched to Microsoft FrontPage which allowed my flexibility with the coding but also inserted a lot of unnecessary code.  Despite a "revamp" in 2006 - which was mostly just a redesigned front page and a palette swap from black to white - the atlas pages haven't truly changed much since.  Sure, there have been minor tweaks, but nothing I'd call an overhaul.  I guess the tables made sense when I only had a few maps on each page to begin with but maybe not now when we've got over 12000 and the biggest sections have 2000+ maps each.



For the possible revamp that keeps on coming up in discussion, the atlas structure is pretty much the main concern as to why we should even have a revamp.  So if and when I get to that, expect something more dynamic and efficient, ie. only pulling up the requested information.

That's why you should use Firefox.



But, glad to know you're at least aware of the problem, have you looked into PHP any?