VGMaps

Site Boards => Message Board Help => Topic started by: Peardian on June 24, 2010, 09:12:46 PM



Title: Session Verification Failed?
Post by: Peardian on June 24, 2010, 09:12:46 PM
Anyone else been getting this recently? Occasionally, on the first time I attempt to edit one of my posts, it has started giving me this error and telling me to try logging in again. Simply going back and trying again works, though, so it's not too much of a hassle.


Title: Re: Session Verification Failed?
Post by: Peardian on September 15, 2010, 07:15:05 AM
Now this is strange. Another error just popped up related to this. It's weird, because I'm having the same errors on another forum running the same software.


"Your session timed out while posting. Please try to re-submit your message."

This happens sometimes when I hit Preview and then try to post afterwards. Is this a cookie setting issue?


Title: Re: Session Verification Failed?
Post by: bustin98 on September 15, 2010, 11:58:04 AM
I ran into this when I had the Google Chrome frame installed in IE8. I don't know the cause of it, and until it happens to more than one user I can't say thats its an issue with the software and not something on your end.

Show me how to re-create it and that will go a long way.


Title: Re: Session Verification Failed?
Post by: TerraEsperZ on September 15, 2010, 01:42:40 PM
That's funny, that used to happen to me when trying to post from work. I use Firefox Portable since my office computer only has IE8. I didn't mention it before because I figured it must have been some sort of network security glitch.


Title: Re: Session Verification Failed?
Post by: Peardian on September 15, 2010, 03:20:56 PM
That's the thing, it's seemingly random. I'll click edit, and it will reject me. Or, I'll preview a post, submit it, and get redirected back to the post page. Attempting the action immediately afterward always works.


Title: Re: Session Verification Failed?
Post by: Peardian on September 22, 2010, 03:15:36 PM
So today in my PHP class we learned about Sessions and SIDs. And then today on another messageboard that uses the same software, we figured out that their verification problem was being caused by the SID being passed through the URL. Unless I'm mistaken and sesc is not what I think it is, there might be a similar issue causing the problems here. :P


Title: Re: Session Verification Failed?
Post by: bustin98 on September 22, 2010, 07:10:56 PM
sesc?

I haven't seen that.

I did a google and found a discussion on SMF's forums, but its with RC2 (we're on 1) and the error crops up when accessing the same scripts across subdomains, which isn't done here either.

All I can suggest, clear your cache, delete your cookies, shut down your computer. Bring it back up and login to the site. See if you can edit one of your posts.

This is an edit of my post...

Another edit: nope, no issues.


Title: Re: Session Verification Failed?
Post by: Peardian on September 22, 2010, 07:44:30 PM
I'm not sure if that will do anything. It's affecting multiple browsers, even ones that never visited this site before. If it is indeed the same problem the other message board was having, it's a problem with how the board software is handling sessions. I hit refresh there and was given a new Session ID, so that's a possible cause. I'll try and pay closer attention to the circumstances that lead up to the error.

Edit: I managed to duplicate it right now. This is indeed the case. While the sesc was being passed through the URL, I hit refresh, and it gave me a new one, which screwed with things. In fact, I was able to cause it to screw up twice in a row (a first) by subsequently trying to edit this post after hitting back.


Title: Re: Session Verification Failed?
Post by: bustin98 on September 22, 2010, 07:46:04 PM
Do you have access to another computer? Like at school, can you get it to happen there?


Title: Re: Session Verification Failed?
Post by: Peardian on September 22, 2010, 07:50:35 PM
I have access to a computer lab Friday afternoon. I'll try and remember to test it there, but I'm guessing I'll get the same results.


Also, I'm curious, but why do all the forum/post numbers end in .0?


Title: Re: Session Verification Failed?
Post by: bustin98 on September 23, 2010, 05:38:05 AM
?? Just how the forum works. I didn't set something to have it that way.


Title: Re: Session Verification Failed?
Post by: Peardian on September 23, 2010, 09:11:35 AM
Ohhhh I see why now. It's used for jumping to posts/page numbers.



Edit: Something about the school's internet prevents me from logging in to... pretty much anything that isn't the school, even on my laptop. I don't expect any different from the lab tomorrow.


Edit: Oops, forgot to check in the lab. Was too busy analyzing pollypocket.com (don't ask). :-[