VGMaps
July 20, 2018, 11:10:39 PM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
 
   Home   Help Search Login Register  
Pages: [1] 2   Go Down
  Print  
Author Topic: Can't access any images on the site  (Read 14850 times)
0 Members and 1 Guest are viewing this topic.
boyo
Newbie
*
Offline Offline

Posts: 5


« on: June 12, 2008, 08:26:16 AM »

Look at this picture.

http://i27.tinypic.com/2zflu9k.gif

I'm using Firefox and it has nothing to do with my cache.

A few months ago I could see all the pictures, but now they all show up as this hotlinking picture.

I can guarantee that nothing on my computer has changed.

I can only assume the server has banned my ip address or something.
Logged
RT 55J
Sr. Member
****
Offline Offline

Posts: 439


« Reply #1 on: June 12, 2008, 12:37:46 PM »

Are you using a proxy?

---

"its a good day to do what has to be done by me and help my brother to defeat the enemys" - John Freeman
Logged


boyo
Newbie
*
Offline Offline

Posts: 5


« Reply #2 on: June 12, 2008, 12:47:53 PM »

No. It worked before. I haven't changed anything.
Logged
Maxim
Hero Member
*****
Offline Offline

Posts: 972



« Reply #3 on: June 13, 2008, 05:06:26 AM »

What do you see here:



http://adurah.com/step2.html



If it isn't the URL of this page, you have problems.
Logged
boyo
Newbie
*
Offline Offline

Posts: 5


« Reply #4 on: June 13, 2008, 06:37:49 AM »

It says "You came from: http://www.vgmaps.com/forums/index.php?topic=750"
Logged
Maxim
Hero Member
*****
Offline Offline

Posts: 972



« Reply #5 on: June 13, 2008, 08:47:46 AM »

If you're in Firefox, enter about:config in the address bar and type "referer" in the box. It looks like you have it set to 1, but it should be 2.
Logged
boyo
Newbie
*
Offline Offline

Posts: 5


« Reply #6 on: June 13, 2008, 09:06:35 AM »

You're right. That fixed it.

What's the difference between 1 and 2?
Logged
Maxim
Hero Member
*****
Offline Offline

Posts: 972



« Reply #7 on: June 13, 2008, 11:51:04 AM »

0 = don't send a referer

2 = send it for everything

1 = don't send it for images



"nothing on my computer has changed"



Except that Smiley
Logged
boyo
Newbie
*
Offline Offline

Posts: 5


« Reply #8 on: June 13, 2008, 11:59:39 AM »

Yeah, somehow.
Logged
tay
Newbie
*
Offline Offline

Posts: 2


« Reply #9 on: December 06, 2008, 08:53:20 PM »

I have the same problem running on internet explorer. (version 7 i think) I'm sure that the referer is the problem but how do i fix it?



Going to the referer test page earlier in this forum says this:



You came from: Your address bar, a bookmark, or you sent no referer.

Logged
Maxim
Hero Member
*****
Offline Offline

Posts: 972



« Reply #10 on: December 07, 2008, 05:52:23 AM »

It's either something you did to IE, via an add-on, or you have a proxy between you and the internet. Some ad-blockers have this effect.



Jon really ought to change the blocker to allow through blank referers.
Logged
JonLeung
Administrator
*****
Offline Offline

Posts: 3158


« Reply #11 on: December 07, 2008, 07:14:58 AM »

Someone on these forums suggested the code I implemented as-is to prevent hotlinking, if that's where the issue is.



I guess I'll have to go back and find where I stuck that snippet of code (I'm guessing the main root HTML file or root folder).



Would allowing blank referrers let potential bandwidth-sucking hotlinkers in, though?
Logged
Maxim
Hero Member
*****
Offline Offline

Posts: 972



« Reply #12 on: December 08, 2008, 04:37:11 AM »

It'll be in .htaccess in the web root directory. Try this:



RewriteEngine On

RewriteCond %{HTTP_REFERER} !^http://(.+\.)?vgmaps\.com/ [NC]

RewriteCond %{HTTP_REFERER} !^$

RewriteRule .*\.(jpe?g|gif|bmp|png)$ /images/noleech.png [L]



Allowing blank referers will allow:



- people with image referers turned off in Firefox

- people with a proxy that removes the referer (often as a "privacy" option)

- people who copy and paste a direct URL to an image into their address bar

- people who try really hard to rip you off by having their linking page have ".vgmaps.com" in the URL (eg. http://www.mysite.com/imrippingoff.vgmaps.com/somepage.html)



and will block:



- people with regular browser setups who click on a link from another website
Logged
JonLeung
Administrator
*****
Offline Offline

Posts: 3158


« Reply #13 on: December 08, 2008, 05:52:26 PM »

Okay, it's been implemented.  It should work just as Maxim says...



Hope that fixes it!
Logged
Revned
Hero Member
*****
Offline Offline

Posts: 1092



« Reply #14 on: December 08, 2008, 07:18:45 PM »

I can finally open images in tabs now!
Logged

Pages: [1] 2   Go Up
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!
VGMaps.com: The Video Game Atlas

 

Pixel WarehouseVGMuseum.com

Your ad could be here - contact me for advertising inquiries.

 

VGMaps.com is registered with and hosted by

Go Daddy.

Supported by you.

� 2002-2018 Jonathan Leung.

VGMaps.com is an archive of video game maps up since May 6, 2002. Optimized for at least 800 x 600 resolution.

This site does not contain commercial ROMs or any other illegal materials. All directly "ripped" game images are the property of their respective copyright holders. This web site and compass logo are copyrighted by Jonathan Leung 2002-2018.